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Introduction: What are Fusion Tables? 
 
One of the quickest and easiest ways to produce simple maps for your Web site is to use Google’s Fusion 
Tables. Fusion Tables is an online data management application designed for collaboration, visualization 
and publication of data.  
 
Fusion tables allow you to: 
 

 Upload and manage map data 
 Map points, lines or areas 
 Create pushpin, intensity, and other types of maps 
 Create other types of visualizations (charts) 
 Embed your visualizations in a Web site 
 Share and collaborate with others 

 
Fusion Tables does not require knowledge of JavaScript or CSS to make online maps. Some knowledge of 
HTML is useful for styling info boxes and adding more complex features. Fusion Tables maps have 
limited options and functionality compared to custom mapping applications, but they are far easier to 
build. Here are some simple use cases for Fusion Tables maps: 
 

 A biogeographer creates a map of wolf sitings in Wisconsin, publishes the map to a Web site, 
and then updates the map as new sitings are made. 

 A community maps the locations of available commercial properties and posts the map online to 
promote business development. 

 A journalist creates a series of election maps for senate districts in the state and embeds the 
map in an online article. 

 A non-profit organization creates maps of bicycle accident locations to raise awareness of 
bicycle safety. 

 
For a general background on Fusion Tables see the app’s help page: 
 

 https://support.google.com/fusiontables 
  
Google provides several useful tutorials on Fusion Tables to help you import, map and publish your data. 
For a full listing see: 
 

 https://support.google.com/fusiontables/answer/184641  
 
Some particularly useful tutorials are: 
 

 Fusion Tables map basics (https://support.google.com/fusiontables/answer/2527132)  
 Mapping your own data (https://support.google.com/fusiontables/answer/181717)  
 Publishing and sharing maps (https://support.google.com/fusiontables/answer/2562055)  

 
Enhancements to Fusion Tables are quite frequent, since Google classifies it as an “experimental app.” 
New features are summarized here: 

https://support.google.com/fusiontables
https://support.google.com/fusiontables
https://support.google.com/fusiontables/answer/184641
https://support.google.com/fusiontables/answer/2527132
https://support.google.com/fusiontables/answer/181717
https://support.google.com/fusiontables/answer/2562055
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 https://support.google.com/fusiontables/answer/1656859  and 
 https://support.google.com/fusiontables/answer/184641 

 
Recent enhancements include: 
 

 Collaborative data gathering 
 Importing data from mobile devices 
 Importing data from Web forms 
 Making intensity maps and heatmaps 
 Adding charts and street view images to maps 
 Adding your own maps and GPS data 
 Modifying default map symbols 

 
There is also a Fusion Tables API to query, manage and update Fusion Tables data. See 
https://developers.google.com/fusiontables/ for more detail.  
 
 

Objectives of this Technical Paper 
 
This tutorial does not cover all of the enhancements and features of Fusion Tables. Rather it provides an 
overview of the base functionality of Fusion Tables for making simple Web maps. This tutorial shows you 
the basic steps for: 
 

 Making a simple pushpin map from a spreadsheet 
 Customizing icons 
 Publishing this map to a Web site 
 Uploading KML and Shapefiles 

 
 

Getting Started: Creating a Simple Pushpin Map 
 
To create a simple pushpin map you will need a source of point data, and for this tutorial we will start 
with a Microsoft Excel spreadsheet of Wisconsin populated places from GNIS (Geographic Names 
Information System). GNIS is the official repository of place names in the United States. The data was 
obtained from the download link at http://geonames.usgs.gov/domestic/index.html and saved to an 
Excel file. The data was then filtered to include only features with a class equal to “Populated Place.” 
The data includes a place name, county name, latitude and longitude, and several other attributes. 
Populated places in GNIS include incorporated places (cities and villages) as well as unincorporated 
places. There are 2583 records in the GNIS dataset for Wisconsin (at time of download, August 2013). 
 
The sample dataset (WI_gnis_ppls_V1.2.xlsx) is available for download at 
http://www.sco.wisc.edu/images/stories/download/fusion_tables_sample_data  
 

https://support.google.com/fusiontables/answer/1656859
https://support.google.com/fusiontables/answer/184641
https://developers.google.com/fusiontables/
http://geonames.usgs.gov/domestic/index.html
http://www.sco.wisc.edu/images/stories/download/fusion_tables_sample_data
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Excel spreadsheet of GNIS populated places in Wisconsin 

 
Fusion Tables accepts data in various formats, including Microsoft Excel files, OpenDocument 
Spreadsheets, delimited text files (such as .csv files), and KML files. For more information on supported 
file types see https://support.google.com/fusiontables/bin/answer.py?hl=en&answer=171181. There 
are size limits on most files and an overall quota of 250 MB per user. 
 
To produce a map, Fusion Tables requires a field (or fields) that refers to the location of each feature. In 
the GNIS example, the latitude and longitude fields will be used. These fields are already in decimal 
degree format. If you have lat-long values that are not in decimal degree format, you will need to 
convert these to decimal degree format before importing into Fusion Tables. 
 
Fusion Tables can also use an address field to locate data, and records will be automatically geocoded as 
the map is created. Likewise, Fusion Tables will recognize other location fields such as county names. 
 
Fusion Tables is integrated into Google Drive (where Google docs are stored). Before importing the Excel 
file, you will have to use your Google account to login to Google Drive at https://drive.google.com.  (You 
will need to create a Google account if you do not have one.)   
 
Once logged in to Google Drive, click the Create button in the upper left portion of the window, and 
choose Fusion Table (experimental)  from the drop down menu (see figure below).  If you haven’t used 
Fusion Tables before, click on “Connect more apps” at the bottom of the menu.  Once the “Connect apps 
to Drive” window pops up, search for Fusion Tables and select Connect.   
 

 
Creating a new Fusion Table 

 

https://support.google.com/fusiontables/bin/answer.py?hl=en&answer=171181
https://drive.google.com/
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This will open a new tab in your browser, and you will be presented with the following window:  
 

 
Importing a new table in Fusion Tables 

 
Navigate to your file using the Choose File button. Once your file has been selected click the Next 
button.  Optionally, you can specify the row in which the column names are located (see figure below).  
 

 
Configuring the import 

 
Clicking Next again takes you to a form that lets you add some simple metadata. Hitting the Finish 
button begins the file import operation. 
 
Once the file has been imported, choose Edit > Change columns. In the GNIS example, the latitude and 
longitude columns have been autodetected by Fusion Tables as a two-column Location field. (Note that 
longitude continues to be defined as a Number, but that it is paired with latitude which is defined as a 
Location field.) 
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Viewing and configuring columns in Fusion Tables 

 
Since Fusion Tables autodetected the location fields correctly, there is no need to modify any field 
definitions. But if needed, you could add or change the location fields. If you do not have latitude or 
longitude, you could use address data. Fusion Tables will geocode the data when the map is first made. 
There are other attributes that can be adjusted from this box by using the Type and Format drop down 
menu.  This will ensure your data is properly visualized once a map is made. You can rename the 
columns in the Name box from this menu as well. 
 
Now you’re ready to make a map. To do so, choose the Map of latitude tab for your imported datset. In 
our example, the resulting map window is shown below. 
 

 
A simple pushpin map of GNIS populated places in Wisconsin 
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Next Steps: Customizing the Map 

Your map can be customized in a few ways. For example,click on the Map of Latitude > Change info 
window… button and click the check boxes to select or deselect attributes for display. 
 

 
 

Configuring the information window for the map 
 
Clicking on the Custom tab will allow you to modify the HTML code to change labels, text styles, colors, 
and so on. 
 

 
Customizing the information window 

 
 



Quick and Easy Web Maps with Google Fusion Tables | SCO Technical Paper 8 

 

The information window below has been customized to show only selected columns of data. 
 

 
Customized information window 

 
The pushpin symbol can also be changed. To do this click on Map of Latitude > Change feature styles... 

 

 
Customizing the pushpin symbol 

 
In addition to these simple pushpin and dot icons, Fusion Tables supports other basic Google icons that 
can be found at https://www.google.com/fusiontables/DataSource?dsrcid=308519. You can click on the 
above link and zoom into the icon cluster to see what these icons look like.  
 
To insert these icons into your map you will need to insert a new column into your imported table by 
selecting Edit > Add column. To keep things simple, give this new column a Column Name of Icons and 
accept the defaults for Type and Format (see below). 
 

https://www.google.com/fusiontables/DataSource?dsrcid=308519
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Adding a new column 

 
Now, switch to the Rows 1 tab to view the tabular data you imported. Find the row in the table that you 
want to modify. For example, if you want to use a custom icon for Madison, find that row in the table. 
Note that to locate a specific row without having to scroll through your entire list, you can select the 
drop down menu from the name_place column heading and click Find… 
 
Now double-click the cell you want to modify. This will be the cell corresponding to the Madison row 
and the Icons column. Enter capital_big_highlight in the Icons field in the dialog box. If the Icons field is 
left blank for a row, the symbol will default to the small red dot. Therefore, if a variety of icons are 
desired the Icons field needs to be filled out for every row.   
 
Once an icon scheme is chosen, return to the map view.  Click on the Change feature styles... button, 
click on the Column tab, click Use icon specified in a column, and select Icons as the column to use. 
When you save this, the point symbol for Madison will change. 
 
This method works best when working with small datasets. If you wish to apply custom icons to larger 
datasets it is best to add a column and specify the names of icons for each row before importing your 
spreadsheet into Fusion Tables. Fusion Tables has also added the ability to merge tables to apply map 
symbols. In other words, you can create a look-up table with the map symbols defined for each category 
on your data, then merge this table with your data using a named icon column as in the above example. 
More details are provided on the Fusion Tables site at 
https://support.google.com/fusiontables/answer/2476954.  
 
 

Sharing and Publishing the Map 
 
To share the map, click the Share button in the upper right of your map window. You can invite people 
to view or edit the map, and also specify the visibility. If the map is going to be shared on the Web or 
embedded in a Web site, it needs to be available with no sign-in required. 

https://support.google.com/fusiontables/answer/2476954
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Specifying sharing options 

 

 
Specifying sharing options 

 
Now that the sharing options have been specified, the map can be embedded in a website. To make 
sure the default view of the map is correct, you should set the map center and zoom level. The easiest 
way to do this is to zoom and center your maps as desired,  then get an embeddable link by selecting 
Tools > Publish. Copy the HTML code from the small window that opens above the map. The code will 
look similar to the following: 
 

<iframe width="500px" height="300px" scrolling="no"  
src="http://www.google.com/fusiontables/embedviz?viz=MAP&q=select+col0%2C+col1
%2C+col2%2C+col3%2C+col4%2C+col5%2C+col6%2C+col7%2C+col8%2C+col9%2C+col10
%2C+col11%2C+col12%2C+col13%2C+col14+from+1164973+&h=false&lat=44.71983445
&lng=-89.89321955&z=7&t=1&l=col9"></iframe> 

 
Parameters highlighted in yellow are ones that you may want to modify when embedding the map in a 
Web site. The width and height parameters define the size of the map. The lat and lng parameters 
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define the center point of the map when it is first displayed, and the z parameter gives the zoom level.  
For this example, we will simply embed the HTML code into a standard Web page.  
 

 
Embedding the map using an HTML editor 

 
The resulting page might look something like this: 
 

 
The embedded map 
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Working with KML and Shapefiles 
 
Fusion Tables also has the ability to work with other types of geodata, such as KML and Shapefiles. With 
these types of files, users can import line and polygon data. You can upload a KML (.kml) file to Fusion 
Tables with no conversion required. This is especially useful if you’re exporting from Google Earth. 
However, Fusion Tables cannot natively handle Shapefiles (.shp) so to import this format into Fusion 
Tables, a series of additional steps is required.  
 
For this example we will work with a Shapefile of Wisconsin counties from the US Census Bureau. This 
Shapefile can be downloaded from http://www.census.gov/cgi-bin/geo/shapefiles2010/main. Under 
Select a layer type select Counties (and equivalent) and then chose Wisconsin. The shapefile will be 
downloaded in compressed ZIP format. The sample dataset (tl_2010_55_county10) is also available for 
download at http://www.sco.wisc.edu/images/stories/download/fusion_tables_sample_data  in both 
compressed and uncompressed formats.  
 
There are a number of different options for converting a Shapefile to KML.  The first uses a combination 
of ArcMap and Google Earth to convert the file manually.  The second method uses QGIS, an open 
source GIS program.  If you don’t have ArcMap and do not want to download the whole QGIS software 
package, the third option is a Website that allows you to drag and drop a zipped Shapefile into their 
converter and will output a KML file for you to download.   

ArcGIS and Google Earth Conversion. To convert your Shapefile manually, add it as a layer in ArcMap. 
Next, open ArcToolbox, and select Conversion Tools > To KML > Layer to KML. 
 

 
Converting to KML 

 
A dialogue box will open. For the Layer field select your Shapefile, for the Output File select the target 
directory and a name for the exported file, and for Layer Output Scale simply type “1”. Let all other fields 
default and select OK to run the script.  
 

http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.sco.wisc.edu/images/stories/download/fusion_tables_sample_data
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A box will pop up telling you the layer has successfully been converted to KML. Now open the target 
directory specified in the previous step and find your new file. Note that your exported file is actually a 
KMZ which cannot be read directly by Fusion Tables. To fix this, open the KMZ file in Google Earth. Select 
File > Save > Save Place As which will open a dialog box. Pick a new name for the file and under Save as 
type be sure to change it to KML. Save the file. 
 
QGIS Conversion.  This method is much simpler than the method used above and the attribute table of 
the Shapefile is also preserved.  Open QGIS and click the Add Vector Layer button and then Browse and 
select your Shapefile and click Open.  After your layer is added, right click on it in the Layers area on the 
left side of the screen and select Save As.  Use the Format drop down menu to select Keyhole Markup 
Language (KML) and name your file.  Once you’ve done this click OK.  Once you see the message Export 
to vector file has been completed you are all done.  Now you can import the KML file into Fusion Tables. 

 

 

Add Vector Layer button 

 

Rename and Select KML in Format dropdown menu 

 

Automated Conversion.  This method utilizes the converter on the website 
http://www.mapsdata.co.uk/online-file-converter/.  To use this converter your Shapefile must be 
contained in a zipped folder.  Once this is done, you can either drag the zipped folder into the box that 
says Drop file or Click to browse or click that same box to browse to the directory and select the zipped 
folder.  After the conversion is complete you will automatically be prompted to save the new KML file in 
your downloads folder.  After you’ve saved the KML file you can upload it into Fusion Tables.  

http://www.mapsdata.co.uk/online-file-converter/
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Drag and drop zipped file here or click to browse to zipped file 

Now you can import the KML file into Fusion Tables.  Begin by selecting Create > FusionTable > Choose 
File.  After selecting your KML file, click Next and ensure that your columns names row is correctly 
identified, and then click Next.  In this window you can rename your table if you desire and you can add 
any additional metadata.  Once you satisfied click Finish.  Now, to view your map, select the Map of 
Geometry tab. 
 

 
Imported KML file based on Shapefile 

 
As a final alternative, Google suggests using http://www.shpescape.com for converting and importing a 
zipped shapefile directly into Fusion Tables (https://support.google.com/fusiontables/answer/2592829).  
 

 

http://www.shpescape.com/
https://support.google.com/fusiontables/answer/2592829
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Creating a Heatmap 
 
Fusion Tables can also be used to create a heatmap. A heatmap shows the density of point observations 
in different colors, from cool to warm (hence the name “heatmap”). To make a heatmap in Fusion 
Tables, simply go to the Map of latitude tab, and choose Change Map from the Tools menu. A Heatmap 
entry will now appear in the left-hand panel. By clicking on this entry, you will be able to manipulate 
several parameters to create a custom heatmap. 
 

 
Heat map showing the density of populated places in southeast Wisconsin 

 
 

Known Problems 
 
As Fusion Tables grows in complexity, the number of issues and bugs have also increased. See 
https://code.google.com/p/fusion-tables/ for a discussion of software bugs, issues and feature requests. 
 

 
Google Maps Engine Lite (Beta) 
 
A new, free and stripped-down version of the Google Maps Engine called Google Maps Engine Lite 
(Beta) was released in March 2013.  It allows users more control over the map they are creating than 
allowed in maps created using Google Fusion Tables. 
 
Google Maps Engine Lite offers the ability to draw directly on top of the basemap (create points, lines 
and polygons by hand) or import tabular data that has a geographic field of some sort 
(Latitude/Longitude or Addresses). The user also has the ability to add multiple layers to an individual 
map, which can be turned on and off at their discretion. Users have much more flexibility when it comes 
to different labeling and symbolization options as well. Each point, line or polygon can be styled 
individually or entire layers can be modified and styled at the same time. Google Maps Engine Lite offers 

https://code.google.com/p/fusion-tables/
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different basemap options including the Google Maps standard basemap, satellite imagery, and a 
number of different neutral colored and gray scale maps. 
 
While Google Maps Engine Lite offers more than Fusion Tables, there are a number of limitations as 
well.  It can only handle CSV, Excel, My Map or Google Drive Spreadsheet files, so data stored in KML 
files or a Google Fusion Table are not currently supported.  There is also a limit of 100 records for a given 
layer, which can be a major constraint depending on the size of the dataset you are working with.  Maps 
Engine Lite is only for personal and non-commercial use.  To learn more about the acceptable uses read 
the program policy at 
http://www.google.com/enterprise/earthmaps/legal/us/gme_program_policies.html. 
 

 
Resources 
 
There are many more options available in Fusion Tables for management, display, and sharing of your 
data. In addition to the resources identified above, there is a help forum at 
 

 https://groups.google.com/group/fusion-tables-users-group  
 
Also be sure to read Google’s privacy policy and terms of use at 
 

  https://www.google.com/fusiontables  
 
 
  

http://www.google.com/enterprise/earthmaps/legal/us/gme_program_policies.html
https://groups.google.com/group/fusion-tables-users-group
https://www.google.com/fusiontables



